summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35d3f3f1ad08..ec6b4a5a0464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,9 @@ pkgdesc='Qt/C++ display management library'
arch=(x86_64 aarch64)
url="https://gitlab.com/kwinft/disman"
license=(LGPL)
-depends=(wrapland kcoreaddons5 qt5-x11extras)
-provides=("disman")
-conflicts=("disman")
+depends=('wrapland' kcoreaddons5 kwayland5 qt5-x11extras)
+provides=('disman')
+conflicts=('disman')
makedepends=(extra-cmake-modules git appstream)
source=("https://gitlab.com/kwinft/disman/-/archive/disman@$pkgver/disman-disman@$pkgver.tar.gz")
sha1sums=('02ab18a807a87124ecb8451db5359f3ec7bfbea6')
@@ -24,7 +24,8 @@ prepare() {
build() {
mkdir -p build
cd build
- cmake ../$pkgname
+ cmake ../$pkgname \
+ -DCMAKE_BUILD_TYPE=Release
}
package() {