summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de118865ba7a..436fe95a6e82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,18 @@
-# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=distro-info-data
-pkgver=0.56
+pkgver=0.59
pkgrel=1
pkgdesc="information about the distributions' releases (data files)"
arch=('any')
url="http://packages.debian.org/sid/distro-info-data"
license=('MIT')
-depends=()
-makedepends=('python2-bin')
+checkdepends=('python')
options=(!emptydirs)
source=(http://ftp.debian.org/debian/pool/main/d/$pkgname/${pkgname}_${pkgver}.tar.xz)
-sha256sums=('74b01674a64db5911bce62e843e3822c12ebae40b3587c3432fc25a8fd606cfe')
-
-build() {
- cd "$srcdir/$pkgname"
- sed -i '1s/python$/python2/' validate-csv-data
-}
+sha256sums=('4660edf1de1b18d016d41da969f9c003f45dcbeb2e39be426ba1cc260dea3326')
check() {
cd "$srcdir/$pkgname"
@@ -27,7 +22,8 @@ check() {
package() {
cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir/" install
- install -Dm644 debian/copyright $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -D -m 644 debian/copyright "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m 644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
}
# vim:set ts=2 sw=2 et: