summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e13d58e9b23a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Andrejs Mivreņiks <gim at fastmail dot fm>
+# Contributor: Apkawa <apkawa at gmail dot com>
+pkgname=django-docs
+pkgver=1.8
+pkgrel=1
+pkgdesc="Docs for Django's release"
+arch=('any')
+url='https://docs.djangoproject.com/en/'
+license=('GPL')
+makedepends=('unzip')
+source=("https://docs.djangoproject.com/m/docs/django-docs-${pkgver}-en.zip")
+noextract=("django-docs-${pkgver}-en.zip")
+# They make minor changes to the ZIP archive contents every now and then,
+# so we have to skip hash sum check.
+sha256sums=('SKIP')
+
+prepare() {
+ unzip "django-docs-${pkgver}-en.zip" -d "$srcdir/html"
+}
+
+package() {
+ install -d "${pkgdir}/usr/share/doc/django/"
+ cp -r "$srcdir/html" "${pkgdir}/usr/share/doc/django/"
+}
+