summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c6cc0fea2d2..b46f4834b722 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=dkms-sorted
pkgver=2.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='Dynamic Kernel Modules System (modified alpm hook to handle dependencies) - experimental'
arch=('any')
url='https://github.com/dell/dkms'
@@ -14,23 +14,34 @@ makedepends=('git')
optdepends=('linux-headers: build modules against the Arch kernel'
'linux-lts-headers: build modules against the LTS kernel'
'linux-zen-headers: build modules against the ZEN kernel'
- 'linux-grsec-headers: build modules against the GRSEC kernel')
+ 'linux-hardened-headers: build modules against the HARDENED kernel')
backup=('etc/dkms/framework.conf')
source=("git+https://github.com/dell/dkms.git#tag=v${pkgver}"
'dkms-install.hook'
'dkms-remove.hook'
- 'alpm-hook')
+ 'alpm-hook'
+ '0001-Revert-Make-newly-installed-modules-available-immedi.patch')
provides=('dkms')
conflicts=('dkms')
sha256sums=('SKIP'
'6f2fe43f98cd3e043330e599689d3471108e5022ca7edf69ad645f609ccc33ac'
'a145a3a8880449a8bc824374b8409750f3cb7c003395fff5a8b9e5ff803c1328'
- '6ca388b4f3a65cc18a737946090ef96d56a832cc0f531bf2adbbc15545ca8cdc')
+ '6ca388b4f3a65cc18a737946090ef96d56a832cc0f531bf2adbbc15545ca8cdc'
+ '124b821b1b44ba365d915945825bcf32c1077655c3a98eb1644de56b6abfcd09')
prepare() {
cd dkms
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+
# /usr move
msg2 '/usr move patching'
for i in dkms{,_framework.conf,.bash-completion,.8,_common.postinst}; do