summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 420cb23fa886..771dbcd86d7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,18 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=dktools
-pkgver=4.23.0
+pkgver=4.24.0
pkgrel=1
pkgdesc="Collection of tools by Dirk Krause, including converters, daemons, Perl modules, development tools, administration tools and printing tools."
arch=('i686' 'x86_64')
url="http://dktools.sourceforge.net"
-license=('dktools-license')
-groups=()
+license=('custom')
depends=('wxgtk3' 'netpbm' 'net-snmp')
makedepends=('wxgtk3') # also optional runtime dependency for wxbmpp, wxdkct and wximgsz
optdepends=('wxgtk3: for wxbmpp, wxdkct and wximgsz'
'libmariadbclient: for itadmin')
source=(http://sourceforge.net/projects/dktools/files/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz)
-sha256sums=('0839dceb702e9e82729da3d2af854abb57806442e8c59226ee7af0c64e08721c')
+sha256sums=('b677ab7a2efc6c9e02e89eadc914fa125e5287d936d6c26a8add7b253a354864')
build() {
cd $pkgname-$pkgver
@@ -25,7 +24,8 @@ build() {
package() {
cd $pkgname-$pkgver
make -i DESTDIR="$pkgdir" install
- rm -rf "$pkgdir"/var/run
+ rm -r "$pkgdir"/var
install -Dm755 -t "$pkgdir"/usr/bin/ "$pkgdir"/usr/sbin/*
rm -r "$pkgdir"/usr/sbin/
+ install -Dm644 bsdlic.txt "$pkgdir"/usr/share/licenses/$pkgname/bsdlic.txt
}