summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c64e48cbd5e..477f8812a393 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,16 @@
# Maintainer: Devin Pohl <pohl.devin@gmail.com>
+# -------------------------------------------------------
+# PLUGINS
+# -------------------------------------------------------
+# If you'd like to compile in plugins, add the names here
+# For a list of available plugins, see the git repo
+# or run `make plugins` in the cloned repo
+PLUGINS=""
+
_pkgname=dmenu
pkgname=$_pkgname-rs
-pkgver=5.1.0.0.g906941c
+pkgver=5.2.0.0.g38a8ad8
pkgrel=1
pkgdesc="A 1:1 port of dmenu, rewritten in Rust"
arch=('i686' 'x86_64')
@@ -22,11 +30,11 @@ pkgver() {
build() (
cd dmenu-rs
- make
+ make PLUGINS="$PLUGINS"
)
package() (
cd $pkgname
- make PREFIX=/usr DESTDIR="$pkgdir" install
+ make PREFIX=/usr DESTDIR="$pkgdir" PLUGINS="$PLUGINS" install
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
) \ No newline at end of file