summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9134ef527ce9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Karol Babioch <karol@babioch.de>
+
+pkgname=('dnsdiag')
+pkgver=1.6.3
+pkgrel=1
+pkgdesc='DNS Diagnostics and Performance Measurement Tools'
+arch=('any')
+url='https://dnsdiag.org/'
+license=('BSD')
+depends=('python' 'python-dnspython' 'python-cymruwhois')
+makedepends=('git' 'python-setuptools')
+source=("git+https://github.com/farrokhi/dnsdiag.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ install -Dm0644 LICENSE* "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+