summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4f0971cdff6..3f4feef0f7ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
# Maintainer: Ben Wolsieffer <benwolsieffer@gmail.com>
_github_url=https://github.com/lopsided98/dnsupdate
pkgname=dnsupdate
-pkgver=0.1
-pkgrel=2
+pkgver=0.2
+pkgrel=1
pkgdesc="A modern and flexible dynamic DNS client"
arch=('any')
url="${_github_url}"
license=('GPL3')
depends=('python-requests' 'python-yaml')
-makedepends=('python-setuptools')
+makedepends=(
+ 'python-setuptools'
+ 'python-sphinx'
+ 'python-sphinx-argparse'
+)
optdepends=(
'python-beautifulsoup4: router address scraping'
'python-netifaces: local interface address support'
)
conflicts=('dnsupdate-git')
-provides=('dnsupdate')
-source=(${pkgname}::git+${_github_url}.git#tag=$pkgver)
+source=(${pkgname}::git+${_github_url}.git#tag=${pkgver})
sha256sums=('SKIP')
build() {
cd "${srcdir}/${pkgname}"
python setup.py build
+
+ # Build man pages
+ python setup.py build_docs -b man
}
package() {
@@ -29,6 +35,10 @@ package() {
python setup.py install --skip-build --root="${pkgdir}" --optimize=1
install -Dm644 dnsupdate.service -t "${pkgdir}/usr/lib/systemd/system/"
+
+ cd build/docs/man
+ install -Dm644 "dnsupdate.1" -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm644 "dnsupdate.5" -t "${pkgdir}/usr/share/man/man5/"
}
# vim:set ts=4 sw=4 et: