summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6049e8056752
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=dobiestation
+pkgrel=1
+pkgver=e4b4313be82ca341c862308ebe466b473d5acef9
+pkgdesc='A Dog based emulator for the ps2'
+arch=(x86_64)
+url=https://github.com/PSI-Rockin/DobieStation/
+license=('GPL')
+groups=()
+depends=(qt5-base)
+makedepends=(
+gcc
+cmake
+git
+)
+provides=(dobiestation)
+conflicts=(dobiestation)
+replaces=(dobiestation)
+
+prepare()
+{
+ git clone https://github.com/PSI-Rockin/DobieStation.git
+ cd DobieStation
+ mkdir build && cd build
+ cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo
+}
+
+build() {
+ cd DobieStation && cd build
+ make
+}
+
+package() {
+ cd DobieStation && cd build
+ sudo make install
+} \ No newline at end of file