summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ff20924e92f..4037e18f2ffc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=dokku
pkgver=0.14.2
-pkgrel=2
+pkgrel=3
pkgdesc="Docker powered mini-Heroku in around 100 lines of Bash."
arch=(any)
url="https://github.com/dokku/dokku"
@@ -12,6 +12,7 @@ license=(MIT)
depends=(
'bind-tools'
'docker'
+ 'go'
'gliderlabs-sigil'
'herokuish'
'net-tools'
@@ -26,31 +27,39 @@ source=(
"${pkgname}.install"
)
sha256sums=('39c4ba9c8a84f60f21bbf4cadd80a9af76e348ee01b0a0843ef614a1253e9674'
- '391a0a4ee19fabff11e6ea73425c6ebfe8a9a1f240d228891b97d4b3207a6851')
+ 'c2d7561e5e9931b13421af629672fe417ab36db0f803cadacbf3614507cc0601')
install="${pkgname}.install"
+prepare() {
+ # Setup go directory
+ mkdir -p gopath/src/github.com/dokku
+ ln -rTsf "${srcdir}/${pkgname}-${pkgver}" "gopath/src/github.com/dokku/${pkgname}"
+ export GOPATH="${srcdir}/gopath"
+
+ # Get go dependencies
+ go get github.com/ryanuber/columnize
+}
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
# Install executable
install -Dm755 dokku "${pkgdir}/usr/bin/dokku"
- # Build go plugins
- make go-build
+ # Add .core and build go plugins
+ for plugin in plugins/*; do
+ if [ -e "${plugin}/Makefile" ]; then make -C "${plugin}" build; fi
+ touch .core
+ done
+
+ # Clean go plugins
+ for plugin in plugins/*; do
+ if [ -e "${plugin}/Makefile" ]; then make -C "${plugin}" src-clean; fi
+ done
# Move all files in place
mkdir -p "${pkgdir}/var/lib/dokku/core-plugins/available"
cp -r plugins/* "${pkgdir}/var/lib/dokku/core-plugins/available"
- cp common.mk "${pkgdir}/var/lib/dokku/core-plugins/common.mk"
-
- find plugins/ -mindepth 1 -maxdepth 1 -type d -printf '%f\n' | while read plugin; do
- # Clean plugins
- cd "${pkgdir}/var/lib/dokku/core-plugins/available/${plugin}"
- if [ -e Makefile ]; then make src-clean ;fi
-
- touch "${pkgdir}/var/lib/dokku/core-plugins/available/${plugin}/.core"
- done
- rm "${pkgdir}/var/lib/dokku/core-plugins/common.mk"
# Version
echo $pkgver > "${pkgdir}/var/lib/dokku/VERSION"