summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 29 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8655f8eb32d1..bdbe37c78309 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r19176.gaaedc2827d'
+pkgver='5.0.r19452.g4dc4b28db4'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -14,8 +14,8 @@ arch=('x86_64' 'aarch64')
url="https://$_mainpkgname.org"
license=('GPL2')
depends=(
- 'alsa-lib' 'bluez-libs' 'cubeb' 'enet' 'hidapi' 'libevdev' 'libgl' 'libmgba'
- 'libpulse' 'libspng' 'libx11' 'libxi' 'libxrandr' 'lzo' 'mbedtls' 'minizip-ng'
+ 'alsa-lib' 'bluez-libs' 'cubeb' 'enet' 'hidapi' 'libevdev' 'libgl' 'libpulse'
+ 'libspng' 'libx11' 'libxi' 'libxrandr' 'lzo' 'mbedtls2' 'minizip-ng'
'pugixml' 'qt6-base' 'sfml' 'zlib'
'libavcodec.so' 'libavformat.so' 'libavutil.so' 'libcurl.so' 'libfmt.so'
'libminiupnpc.so' 'libswscale.so' 'libudev.so' 'libusb-1.0.so'
@@ -25,14 +25,20 @@ optdepends=('pulseaudio: PulseAudio backend')
source=(
"$pkgname::git+https://github.com/$_mainpkgname/$_projectname"
"$pkgname-implot::git+https://github.com/epezent/implot.git"
+ "$pkgname-mgba::git+https://github.com/mgba-emu/mgba.git"
+ "$pkgname-rcheevos::git+https://github.com/RetroAchievements/rcheevos.git"
"$pkgname-vma::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git"
"$pkgname-zlibng::git+https://github.com/zlib-ng/zlib-ng.git"
+ "$pkgname-mbedtls2.diff::https://github.com/$_mainpkgname/$_projectname/pull/11847.diff"
'minizip-ng.diff'
)
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '062513965a9a037d3e755c4fe071a0454d3f71738d7659698ce7287019cb986e30dbdc29a43910117d284fa058426c937896e896c3007961a7daeb2a2422a9aa'
'b469597fe9b4e9be6ae9ab0330fe5e3d6b944a73505775ff75f9895ae4843768f3815d4b5b8e227d6d2e87c3f4882d6d7262f9df85be0aaddf46730a7afa16dd')
_sourcedirectory="$pkgname"
@@ -42,26 +48,27 @@ prepare() {
if [ -d 'build/' ]; then rm -rf 'build/'; fi
mkdir 'build/'
+ # Fix mbedtls dependency to use mbedtls2
+ patch --forward -p1 < "$srcdir/$pkgname-mbedtls2.diff"
+
# Fix minizip-ng name for Arch
patch --forward -p1 < "$srcdir/minizip-ng.diff"
- # Provide implot submodule
- _implotpath='Externals/implot/implot'
- git submodule init "$_implotpath"
- git config "submodule.$_implotpath.url" "$srcdir/$pkgname-implot/"
- git -c protocol.file.allow=always submodule update "$_implotpath"
-
- # Provide vma submodule
- _vmapath='Externals/VulkanMemoryAllocator'
- git submodule init "$_vmapath"
- git config "submodule.$_vmapath.url" "$srcdir/$pkgname-vma/"
- git -c protocol.file.allow=always submodule update "$_vmapath"
+ # Provide submodules
+ declare -A _submodules=(
+ [implot]='implot/implot'
+ [mgba]='mGBA/mgba' # The current version of mgba in the repos is not compatible with Dolphin
+ [rcheevos]='rcheevos/rcheevos'
+ [vma]='VulkanMemoryAllocator'
+ [zlibng]='zlib-ng/zlib-ng'
+ )
- # Provide zlib-ng submodule
- _zlibngpath='Externals/zlib-ng/zlib-ng'
- git submodule init "$_zlibngpath"
- git config "submodule.$_zlibngpath.url" "$srcdir/$pkgname-zlibng/"
- git -c protocol.file.allow=always submodule update "$_zlibngpath"
+ for _submod in "${!_submodules[@]}"; do
+ _path="Externals/${_submodules[$_submod]}"
+ git submodule init "$_path"
+ git config "submodule.$_path.url" "$srcdir/$pkgname-$_submod/"
+ git -c protocol.file.allow=always submodule update "$_path"
+ done
}
pkgver() {
@@ -70,14 +77,16 @@ pkgver() {
}
build() {
+ # The dolphin-emu package in the repos MAKE_BUILD_TYPE=None for some reason, so we use it as well
cd "$srcdir/$_sourcedirectory/"
cmake -S '.' -B 'build/' -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DDISTRIBUTOR=archlinux.org \
-DENABLE_TESTS=OFF \
+ -DENABLE_AUTOUPDATE=OFF \
-DUSE_SHARED_ENET=ON \
- -DUSE_RETRO_ACHIEVEMENTS=OFF \
+ -DCMAKE_DISABLE_FIND_PACKAGE_LIBMGBA=True \
-Wno-dev
cmake --build 'build/'
}