summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37563e53a420..c2fa947ed8d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,6 +25,9 @@ pkgver() {
}
prepare() {
+ sed -i -e 's/#include <vector>/#include <vector>\n#include <curl\/curlver\.h>/' Source/Core/Common/Analytics.h
+ sed -i -e 's/#include "Common\/Flag\.h"/#include "Common\/Flag\.h"\n\n#if LIBCURL_VERSION_MAJOR >= 7 \&\& LIBCURL_VERSION_MINOR >= 50\ntypedef struct Curl_easy CURL;\n#else/' Source/Core/Common/Analytics.h
+ sed -i -e 's/typedef void CURL;/typedef void CURL;\n#endif/' Source/Core/Common/Analytics.h
cd dolphin-emu
if [[ -d build ]]; then