summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0cbfe1d01ce4..549f60e0265e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=dolphin-emu
pkgname=${_pkgname}-wayland
-pkgver=5.0.r17269.48c9c224cf
+pkgver=5.0.r17995.8bad821019
pkgrel=1
epoch=1
pkgdesc='A Gamecube / Wii / Triforce emulator, patched with experimental support for Wayland'
@@ -52,11 +52,14 @@ optdepends=('pulseaudio: PulseAudio backend')
options=(!emptydirs)
conflicts=(${_pkgname})
provides=(${_pkgname})
-_commit=48c9c224cf9f82f0f9f2690b7cc6283d7448480c
+_commit=8bad821019721b9b72701b495da95656ace5fea5
source=(
dolphin-emu::git+https://github.com/dolphin-emu/dolphin.git#commit=${_commit}
+ git+https://github.com/mozilla/cubeb.git
git+https://github.com/randy408/libspng.git
+ git+https://github.com/arsenm/sanitizers-cmake.git
git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git
git+https://github.com/zlib-ng/zlib-ng.git
dolphin-emu-wayland-support.patch # Generated by rebasing https://github.com/dolphin-emu/dolphin/pull/8727
dolphin-emu-wayland.desktop
@@ -65,7 +68,10 @@ b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '89f004d45f607383ac31170a03faf0e4ed5a6b7df9278a1e3534782a0adc593ef858434e7afa186854c44e60a65c324de09c4d433dc4c8aeaaccf585aedd7f3c'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'e3dee2a3fb351d6957ba4ba5381a67a1734f9c9135ef9dcd4a3d6eaf85c0357f34c1488add2e6ba4e81a0c70da131ed3db0749bf30c37ea5eb675bf79376ba7f'
'39ff2c0abb4b05583e3e207380fee5c89f096bd31b7fc26de2efe4ad30915b933440515cb34592f7ee48adf3383641138b21f90cfeba3be822424a1a4583d5ae')
prepare() {
@@ -73,11 +79,15 @@ prepare() {
patch -p1 < ${srcdir}/dolphin-emu-wayland-support.patch
- for submodule in Externals/{libspng/libspng,spirv_cross/SPIRV-Cross,zlib-ng/zlib-ng}; do
+ for submodule in Externals/{cubeb/cubeb,libspng/libspng,spirv_cross/SPIRV-Cross,VulkanMemoryAllocator,zlib-ng/zlib-ng}; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../${submodule##*/}
- git submodule update ${submodule}
+ git -c protocol.file.allow=always submodule update ${submodule}
done
+ cd Externals/cubeb/cubeb
+ git submodule init cmake/sanitizers-cmake
+ git config submodule.cmake/sanitizers-cmake.url "${srcdir}"/sanitizers-cmake
+ git -c protocol.file.allow=always submodule update cmake/sanitizers-cmake
}
pkgver() {