summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11b35cdec404
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Albakham <contact@geber.ga>
+
+pkgname=domain-expiration-git
+pkgver=r4.75c369c
+pkgrel=1
+pkgdesc="Checks the expiration dates of domains."
+arch=('any')
+url="https://gitnet.fr/deblan/domain-expiration"
+license=('GPL')
+depends=('php>=7.3' 'whois')
+makedepends=('composer')
+source=("$pkgname::git+https://gitnet.fr/deblan/domain-expiration")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ sed -i "1c\#!/usr/bin/env php" domain-expiration
+ echo "Version ${pkgver} installation"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ composer install
+}
+
+package() {
+ install -d "$pkgdir/"{usr/bin,opt}
+ cp -R $srcdir/$pkgname $pkgdir/opt/$pkgname
+ ln -s /opt/$pkgname/domain-expiration $pkgdir/usr/bin/$pkgname
+}