summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2237464e88a..d1d364ff1a86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: solaraquarion <shlomochoina@gmail.com>
pkgname=domterm-git
-pkgver=2.1.r94.g40e9b1b
+pkgver=2.9.4.r95.g29efa6e
pkgrel=1
pkgdesc="Terminal emulator capable of display html and images from command output"
arch=('x86_64')
@@ -9,27 +9,19 @@ url=https://github.com/PerBothner/DomTerm
license=('BSD')
groups=()
conflicts=(qtdomterm)
-makedepends=('git' 'vim' 'asciidoctor' 'zip' 'json-c')
-depends=(file qt5-webengine qt5-webchannel libwebsockets java-runtime)
-source=('git+https://github.com/PerBothner/DomTerm.git'
- 'git+https://github.com/warmcat/libwebsockets')
-md5sums=('SKIP'
- 'SKIP')
+makedepends=('git' 'vim' 'asciidoctor' 'zip' 'json-c' 'rust' 'jq' 'libsoup' 'atk' 'gtk3' 'webkit2gtk' 'libappindicator-gtk3' 'java-openjfx')
+depends=(qt5-webengine libwebsockets java-runtime webkit2gtk)
+source=('git+https://github.com/PerBothner/DomTerm.git')
+md5sums=('SKIP')
pkgver(){
cd "$srcdir"/DomTerm
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
-
- cd "$srcdir"/libwebsockets
- mkdir build
- cd build
- cmake -DLWS_WITH_SSL=0 -DLWS_WITH_ZIP_FOPS=1 ..
- make
cd "$srcdir"/DomTerm
autoreconf -vfi
- ./configure --with-qtwebengine --with-libwebsockets="$srcdir"/libwebsockets/build --with-javafx --prefix=/usr
+ ./configure --with-qt --with-libwebsockets --with-javafx --with-wry --prefix=/usr
make V=1
}