summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad93769cc2f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tim Wanders <timwanders241@gmail.com>
+_pkgname="doom-launcher"
+pkgname="${_pkgname}-git"
+pkgver=1
+pkgrel=1
+pkgdesc="doom-launcher: A doom mod manager and launcher"
+arch=('any')
+url="https://gitlab.com/tim241/${_pkgname}"
+license=('GPL3')
+
+provides=('doom-launcher')
+conflicts=('doom-launcher')
+depends=('bash' 'dialog' 'gzdoom')
+
+source=("git+https://gitlab.com/tim241/${_pkgname}.git")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --always | sed -e 's|-|.|g'
+}
+
+package() {
+ cd "$_pkgname"
+ install -D -m=0755 doom-launcher "$pkgdir/usr/bin/doom-launcher"
+}