summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6a0bfc41584..2484ba2c18ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,27 +6,26 @@
# Contributor: Dmitry Shilov <stormblast@land.ru>
pkgname=doomsday
-pkgver=2.2.1
-pkgrel=2
+pkgver=2.3.1
+pkgrel=5
pkgdesc="An advanced Doom engine that supports DOOM, Heretic and Hexen."
url="http://dengine.net/"
arch=('i686' 'x86_64')
license=('GPL2')
conflicts=('doomsday-bin')
-provides=('assimp')
-depends=('hicolor-icon-theme' 'qt5-x11extras' 'sdl2_mixer' 'fluidsynth' 'lib32-fluidsynth' 'openal' 'libxrandr' 'minizip')
-makedepends=('imagemagick' 'cmake' 'xorg-server-devel' 'assimp' 'python')
+depends=('hicolor-icon-theme' 'qt5-x11extras' 'sdl2_mixer' 'fluidsynth' 'openal' 'libxrandr' 'minizip')
+makedepends=('imagemagick' 'cmake' 'xorg-server-devel' 'python')
optdepends=('doom1-wad: Doom shareware',
'heretic1-wad: Heretic shareware',
'hexen1-wad: Hexen shareware'
- 'soundfont-fluid')
+ 'soundfont-fluid')
source=("http://files.dengine.net/archive/doomsday-$pkgver.tar.gz")
-sha256sums=('116dad77943658097183a0b7ddb92a3354fb3c6996cddfc0517da1b15ce0e806')
+sha256sums=('feffcb792cf0f4e17f5bf9532f29e5963d6dd8b2872fc9bae10f53044548da04')
build() {
# Enter build directory
- cd $srcdir/$pkgname-$pkgver/$pkgname
+ cd "$srcdir"/$pkgname-$pkgver/$pkgname
# Generate makefiles using qmake
mkdir -p build
@@ -37,11 +36,11 @@ build() {
}
package() {
- cd $srcdir/$pkgname-$pkgver/$pkgname/build
- make install DESTDIR="$pkgdir"
+ cd "$srcdir"/$pkgname-$pkgver/$pkgname/build
+ make install DESTDIR=""$pkgdir""
# Delete the contents of /usr/include/assimp as this package already provides it
- rm -r $pkgdir/usr/include/assimp
+ rm -r "$pkgdir"/usr/include/assimp
# Look for WADs in /usr/share/games/doom by default
mkdir -p "${pkgdir}/etc/doomsday"