summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64a44a814021..e19f2e34f7f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,18 @@
pkgname=doomsday
pkgver=2.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="An advanced Doom engine that supports DOOM, Heretic and Hexen."
url="http://dengine.net/"
arch=('i686' 'x86_64')
license=('GPL2')
conflicts=('doomsday-bin')
-depends=('qt5-base' 'qt5-x11extras' 'sdl2_net' 'sdl2_mixer' 'fmodex' 'wxpython' 'fluidsynth' 'soundfont-fluid' )
+depends=('qt5-base' 'qt5-x11extras' 'sdl2_net' 'sdl2_mixer' 'fmodex' 'wxpython' 'fluidsynth')
makedepends=('imagemagick' 'cmake')
optdepends=('doom1-wad: Doom shareware',
'heretic1-wad: Heretic shareware',
- 'hexen1-wad: Hexen shareware')
+ 'hexen1-wad: Hexen shareware'
+ 'soundfont-fluid')
source=("http://files.dengine.net/archive/doomsday-$pkgver.tar.gz")
sha256sums=('be12b41423d038b1b3df6bf88a7312f1baba7f7a773568b7e66a8a5518b46af5')
@@ -29,7 +30,8 @@ build() {
# Generate makefiles using qmake
mkdir -p build
cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
make
}