summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c14e7b35dc2..678d7bcbafc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=dosbox-staging
pkgver=0.81.0
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="DOS/x86 emulator focusing on ease of use. Based on DOSBox"
arch=('any')
@@ -11,20 +11,20 @@ url="https://github.com/dosbox-staging/dosbox-staging"
license=('GPL2')
depends=('sdl2' 'sdl2_net' 'opusfile' 'alsa-lib' 'libpng' 'iir1' 'sdl2_image' 'hicolor-icon-theme' 'speexdsp' 'libslirp' 'fluidsynth' 'munt' 'zlib-ng')
optdepends=('ncurses')
-makedepends=('meson' 'ninja' 'gcc' 'gzip')
+makedepends=('meson' 'ninja' 'gcc' 'gzip' 'git')
provides=("dosbox")
conflicts=("dosbox")
-source=("https://github.com/dosbox-staging/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('211cbd2fb781bee1e92963f57e8111e22bcaf17a3a6dc11189982a0eea311e9b')
+source=("git+https://github.com/dosbox-staging/dosbox-staging#tag=v${pkgver}")
+sha256sums=('SKIP')
build() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "$srcdir/${pkgname}"
meson setup --prefix "/usr" build
meson compile -C build
}
package() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "$srcdir/${pkgname}"
meson install -C build --destdir "$pkgdir" --skip-subprojects libpng