summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20846e1a786c..a984aa321646 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
# Maintainer: Mike Cuche <cuche AT mailbox.org>
pkgname=dosbox-x
-pkgver=2022.12.26
+pkgver=2023.03.31
pkgrel=1
pkgdesc="x86 emulator with builtin DOS, with patches with more features"
arch=(i686 x86_64 aarch64)
url="http://dosbox-x.com"
license=(GPL)
-depends=(fluidsynth libxkbfile libpng libxrandr mesa ffmpeg4.4 physfs libslirp libpcap)
+depends=(fluidsynth libxkbfile libpng libxrandr mesa ffmpeg physfs libslirp libpcap)
makedepends=(glu)
optdepends=('openglide-git: Third-party 3dfx Glide API support')
conflicts=(dosbox-x-git)
source=(https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v${pkgver}.tar.gz)
-sha256sums=('39fb1ed19ea31e11883aa57655493b3100ac6b328ef59c799b840b9bfdfacb7b')
+sha256sums=('233f487a90654b03f32b290579f24d5b188a65361b8a7787154f5c4cd8f5f144')
build() {
cd $srcdir/dosbox-x-dosbox-x-v${pkgver}
sed -i -e 's/-j3/-j$(nproc)/g' build
- sed -i 's|"$LIBS -lavcodec -lavformat -lavutil -lswscale "`pkg-config libavcodec --libs`|`pkg-config libavcodec libavformat libavutil libswscale libswresample --libs`"$LIBS"|' configure.ac #ffmpeg avcodec fix
- sed -i 's|$LIBS $SDL_LIBS|$LIBS $SDL_LIBS -lm -lGL|' configure.ac #fluidsynth fix
- PKG_CONFIG_PATH="/usr/lib/ffmpeg4.4/pkgconfig" ./build
+# sed -i 's|$LIBS $SDL_LIBS|$LIBS $SDL_LIBS -lm -lGL|' configure.ac #fluidsynth fix
+ ./build
}
package() {