summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3e663d8dfc3..f05568ea05d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mike Cuche <cuche@gmx.com>
pkgname=dosbox-x
-pkgver=0.83.2
+pkgver=0.83.3
pkgrel=1
pkgdesc="x86 emulator with builtin DOS, with patches with more features"
arch=(i686 x86_64)
@@ -14,12 +14,15 @@ conflicts=(dosbox-x-git)
source=(https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v${pkgver}.tar.gz
dosbox-x.png
dosbox-x.desktop)
-sha256sums=('87cfdf515b6c5a71afb3f5b1960d5cd323a0cce5643094713db3cf2ccb82b4bc'
+sha256sums=('48f005949ada1ace8ad8c00bb27fad17d566e5bcdbec8be6078e44f8ad04759a'
'caa164f3d17d414733882d29098cb9cd63faddbdd5580a0c30f1173a63c42475'
'32f290580ec02dedd09908d8a4de10f57b94998f2c1eb597b649208cd87b2d33')
build() {
cd $srcdir/dosbox-x-dosbox-x-v${pkgver}
+ #removing --as-needed compile flag as refered to this: https://github.com/joncampbell123/dosbox-x/issues/1698#issuecomment-655291120
+ export LDFLAGS="${LDFLAGS//,--as-needed}"
+ sed -i -e 's/-j3/-j$(nproc)/g' build
./build
}