summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fcdb61cdceb5..32689f75009d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mike Cuche <cuche AT mailbox.org>
pkgname=dosbox-x
-pkgver=2023.05.01
+pkgver=2023.09.01
pkgrel=1
pkgdesc="x86 emulator with builtin DOS, with patches with more features"
arch=(i686 x86_64 aarch64)
@@ -13,10 +13,17 @@ optdepends=('openglide-git: Third-party 3dfx Glide API support')
conflicts=(dosbox-x-git)
source=(https://github.com/joncampbell123/dosbox-x/archive/dosbox-x-v${pkgver}.tar.gz)
-sha256sums=('0aa75b873978aec41ecfee62bb103d8a17fe3566a3ebf5415245cee0dd032ebb')
+sha256sums=('71bf4477ae1640406fa24023f51766ab158ebf26f0e2f317f6fd7bd84c15b4e6')
build() {
cd $srcdir/dosbox-x-dosbox-x-v${pkgver}
+
+ #Workaround: https://github.com/joncampbell123/dosbox-x/issues/4436
+ export CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions \
+ -Wp,-D_FORTIFY_SOURCE=2 -Wformat \
+ -fstack-clash-protection -fcf-protection"
+ export CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
+
sed -i -e 's/-j3/-j$(nproc)/g' build
./build
}