summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad427cf9c091..4fe70bae2e10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,18 @@ arch=('any')
url="https://github.com/deadc0de6/dotdrop"
license=('GPL')
groups=()
-depends=('python' 'python-jinja' 'python-docopt' 'python-pyaml')
-source=("git+https://github.com/deadc0de6/dotdrop.git")
+depends=('python' 'python-setuptools' 'python-jinja' 'python-docopt' 'python-pyaml')
+makedepends=('git')
+source=("git+https://github.com/deadc0de6/dotdrop.git#tag=v${pkgver}")
md5sums=('SKIP')
+pkgver() {
+ cd "${pkgname}"
+ git describe --abbrev=0 --tags | sed 's/^v//g'
+}
+
package() {
cd "${pkgname}"
- python setup.py install --root="${pkgdir}/"
+ python setup.py install --root="${pkgdir}/" --optimize=1
}