summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05bc2e569160..6348d792c5ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,5 @@
pkgname=dpdk
-pkgver=2.2.0.rc1
-_tag=2.2.0-rc1
+pkgver=16.04
pkgrel=1
pkgdesc='A set of libraries and drivers for fast packet processing'
arch=(x86_64 i686)
@@ -10,28 +9,28 @@ options=(staticlibs)
depends=()
makedepends=(linux-headers libpcap)
checkdepends=()
-source=(http://dpdk.org/browse/dpdk/snapshot/dpdk-$_tag.tar.gz)
-sha1sums=('11af71ffceb8808f5459f76090166dd6e4af808a')
+source=(http://fast.dpdk.org/rel/dpdk-$pkgver.tar.xz)
+sha1sums=('580d8bb773a867dcc85a85e74714f130d0c76da3')
prepare() {
- cd dpdk-$_tag
+ cd dpdk-$pkgver
make config T=x86_64-native-linuxapp-gcc
sed -ri 's,(PMD_PCAP=).*,\1y,' build/.config
sed 's|\bpython\b|python2|' -i mk/rte.sdktest.mk
}
build() {
- cd dpdk-$_tag
+ cd dpdk-$pkgver
make T=x86_64-native-linuxapp-gcc
}
check() {
- cd dpdk-$_tag
+ cd dpdk-$pkgver
# tests fail
# make test T=x86_64-native-linuxapp-gcc
}
package() {
- cd dpdk-$_tag
+ cd dpdk-$pkgver
make T=x86_64-native-linuxapp-gcc DESTDIR="$pkgdir/opt/$pkgname" install
}