summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1be771b0fadf..4a17c40ba4a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,17 @@
# Maintainer: Adrian Bacircea <adrian.bacircea@gmail.com>
pkgname=dpdk-git
-pkgver=v19.08.r64.bd253daa7
+pkgver=v20.08.r6.b9b10ddb4
pkgrel=1
pkgdesc="A set of libraries and drivers for fast packet processing"
arch=("x86_64")
url="https://www.dpdk.org"
license=("custom")
-depends=("numactl" "libpcap" "python" "libelf")
+depends=("numactl" "libpcap" "python" "libelf" "libbsd" "libbpf" "jansson")
makedepends=("git" "meson" "linux-headers")
provides=("dpdk")
options=("staticlibs")
-source=("${pkgname}::git+https://dpdk.org/git/dpdk"
- "Add-prefix-to-install-rpath-for-dpdk-test.patch")
-sha256sums=('SKIP'
- 'b6988c8f103c93ee3216d393f0167f2a174a993a9977f9571cd9dc6a45bcec63')
+source=("${pkgname}::git+https://dpdk.org/git/dpdk")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -22,7 +20,6 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}"
- patch -p1 < "${srcdir}/Add-prefix-to-install-rpath-for-dpdk-test.patch"
}
build() {
@@ -41,9 +38,6 @@ package() {
popd
install -d ${pkgdir}/usr/share/licenses/${pkgname}
install -t ${pkgdir}/usr/share/licenses/${pkgname} license/*
- cd "${pkgdir}"
- mv lib/* usr/lib
- rm -rf lib
}
# vim: set ts=2 sts=2 sw=2: