summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 38 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d64e6c14f93b..70b1054c2e1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,49 @@
# Contributor: Jan Dolinar <dolik.rce@gmail.com>
# Contributor: Andre Klitzing <andre () incubo () de>
pkgname=dput
-pkgver=0.9.6.4
+pkgver=1.0.2
pkgrel=1
pkgdesc="Debian package upload tool"
arch=('any')
url="http://packages.qa.debian.org/dput"
license=('GPL')
-depends=('python2' 'gnupg')
-source=(http://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}_all.deb)
-sha256sums=('2ac0bcf25c3e64728fdbec3c91c16b305b982861e60780ecadff3b97c90bfa8a')
+makedepends=('python-setuptools')
+depends=('python' 'python-debian' 'python-gpgme')
+source=(http://http.debian.net/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.tar.xz)
+md5sums=('67924fcbb7cb17f3344dd3696f1c2619')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
package() {
- ar x ${pkgname}_${pkgver}_all.deb
- tar xzf data.tar.gz -C "$pkgdir/"
- cd "$pkgdir"
- sed -i -e '1s|^#!/usr/bin/python$|#!/usr/bin/python2|' $pkgdir/usr/bin/d{c,p}ut
+ cd "$pkgname-$pkgver"
+
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ mv ${pkgdir}/usr/bin/{execute-,}dput
+ mv ${pkgdir}/usr/bin/{execute-,}dcut
+
+ install -d "${pkgdir}/etc/"
+ install -m644 dput.cf "${pkgdir}/etc/"
+
+ # completion
+ install -d "${pkgdir}/usr/share/bash-completion/completions/"
+ for bc in dput dcut; do
+ install -m644 bash-completion/${bc}.bash "${pkgdir}/usr/share/bash-completion/completions/$bc"
+ done
+
+ # docs
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m644 README TODO doc/FAQ doc/THANKS "${pkgdir}/usr/share/doc/${pkgname}"
+
+ # man pages
+ cd doc/man
+ for file in $(find . -name '*.1' -print); do
+ install -Dm644 $file "${pkgdir}"/usr/share/man/man1/$file
+ done
+ for file in $(find . -name '*.5' -print); do
+ install -Dm644 $file "${pkgdir}"/usr/share/man/man5/$file
+ done
}