summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1a308563889..510d8140738f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: coldbug <coldBug@e.mail.de>
pkgname=dr14_t.meter-git
-pkgver=v1.0.15.r162.g7516e5c
+pkgver=v1.0.15.r190.g9a22d1a
pkgrel=1
pkgdesc="DR14 T.meter is a command line tool for computing the Dynamic Range of your music"
arch=(any)
url="https://github.com/simon-r/dr14_t.meter"
license=('GPL3')
-depends=('python' 'flac' 'lame' 'faad2' 'ffmpeg' 'vorbis-tools' 'python-numpy')
+depends=('python' 'flac' 'lame' 'faad2' 'ffmpeg' 'vorbis-tools' 'python-numpy' 'python-mutagen')
optdepends=('python-matplotlib: plot support for python' 'python-scipy: dyn compression')
-makedepends=('git')
+makedepends=('git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}" "dr14_tmeter")
source=('dr14_t.meter::git+https://github.com/simon-r/dr14_t.meter.git#branch=master')
@@ -22,10 +22,10 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/${pkgname%-git}"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}