summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1910755a9ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=drawing-git
+pkgver=r102.c81c3de
+pkgrel=1
+pkgdesc="Drawing application for the GNOME desktop"
+url="https://wiki.gnome.org/Apps/Tweaks"
+arch=(any)
+license=(GPL)
+depends=(gtk3 python)
+makedepends=(git meson python)
+provides=(drawing com.github.maoschanz.Drawing)
+conflicts=(drawing)
+source=("git+https://github.com/maoschanz/drawing.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd drawing
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ arch-meson drawing build
+ ninja -C build
+}
+
+#check() {
+# meson test -C build
+#}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}