summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7b1914fd410..3d01cceb38eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,21 +6,28 @@
pkgbase='drawpile'
pkgname=("${pkgbase}"{,'-client','-server'})
pkgver=2.1.17
-pkgrel=1
+pkgrel=2
pkgdesc='Collaborative drawing program specially made for use with pen tablets'
arch=('i686' 'x86_64')
url='http://drawpile.net/'
license=('GPL3')
makedepends=('cmake' 'extra-cmake-modules' 'karchive' 'qt5-multimedia' 'qt5-svg' 'qt5-tools' 'qt5-x11extras')
-source=("http://drawpile.net/files/src/${pkgbase}-${pkgver}.tar.gz" "qtfix.diff::https://github.com/drawpile/Drawpile/commit/b46115160c5587aae9306e57d4223906e74ed512.diff")
-sha256sums=('ee7f7ba81e6f1a9c3c32275f84364d10713c24ec040da8cb4b13c3ea6bb09086' '5b9f5d42f0db081496f9c5bde295751dba0e029dac7bf0a0b0c1d32eef60c5de')
+source=(
+ "http://drawpile.net/files/src/${pkgbase}-${pkgver}.tar.gz"
+ "qtfix.diff::https://github.com/drawpile/Drawpile/commit/b46115160c5587aae9306e57d4223906e74ed512.diff"
+ "mhdfix.diff::https://github.com/drawpile/Drawpile/commit/ed1a75deb113da2d1df91a28f557509c4897130e.diff")
+sha256sums=(
+ 'ee7f7ba81e6f1a9c3c32275f84364d10713c24ec040da8cb4b13c3ea6bb09086'
+ '5b9f5d42f0db081496f9c5bde295751dba0e029dac7bf0a0b0c1d32eef60c5de'
+ '4edb006748393df59dcd715e0fafbd8d0a7626852e6782078ace6eee708a93c4')
-_cmakeargs+=('-Wno-dev' '-DKIS_TABLET=ON' '-DSERVER=OFF' '-DSERVERGUI=OFF')
+_cmakeargs+=('-Wno-dev' '-DKIS_TABLET=ON')
prepare() {
cd "${pkgbase}-${pkgver}"
patch --forward --strip=1 --input="${srcdir}/qtfix.diff"
+ patch --forward --strip=1 --input="${srcdir}/mhdfix.diff"
}
build() {