summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 813e8516f91f..1f252d430c61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Samuel Walladge <samuel at swalladge dot id dot au>
pkgname=dreamchess-git
+_pkgname=dreamchess
pkgver=312.c7fad45
-pkgrel=2
+pkgrel=3
pkgdesc="DreamChess - OpenGL Chess Game"
-arch=('any')
+arch=('i686' 'x86_64')
url="https://github.com/dreamchess/dreamchess"
license=('GPL')
# tried to include all necessary deps and none that aren't
# please notify if list not fully correct
-depends=(mxml sdl_mixer sdl_image glew libgl expat)
+depends=(mxml sdl_mixer sdl_image glew hicolor-icon-theme)
makedepends=(git bison)
source=('git://github.com/dreamchess/dreamchess.git')
@@ -22,20 +23,16 @@ pkgver() {
}
build() {
- cd "${srcdir}/dreamchess"
+ cd "${srcdir}/${_pkgname}"
# must autoreconf or missing install-sh
autoreconf -fvi
- ./configure
+ ./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/dreamchess"
+ cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
-
- # removing man pages otherwise pacman complains of filesystem conflict.
- # not sure where the bug is, someone can check it out later
- rm -r ${pkgdir}/usr/local/share/man
}
# vim:set ts=2 sw=2 et: