summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5ffe5db1856..cb57291cc8ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,28 @@
-# Maintainer: Samuel Walladge <swalladge at gmail dot com>
+# Maintainer: Samuel Walladge <samuel at swalladge dot id dot au>
pkgname=dreamchess-git
pkgver=312.c7fad45
-pkgrel=1
+pkgrel=2
pkgdesc="DreamChess - OpenGL Chess Game"
arch=('any')
url="https://github.com/dreamchess/dreamchess"
license=('GNU')
-depends=(bison mxml)
-makedepends=('git')
+
+# tried to include all necessary deps and none that aren't
+# please notify if list not fully correct
+depends=(mxml sdl_mixer sdl_image glew libgl expat libxext)
+makedepends=(git bison)
+
source=('git://github.com/dreamchess/dreamchess.git')
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/dreamchess"
+ cd "${srcdir}/dreamchess"
echo "$(git rev-list --count HEAD).$(git log --pretty=format:'%h' -n 1)"
}
build() {
- cd "$srcdir/dreamchess"
+ cd "${srcdir}/dreamchess"
# must autoreconf or missing install-sh
autoreconf -fvi
./configure
@@ -26,8 +30,12 @@ build() {
}
package() {
- cd "$srcdir/dreamchess"
+ cd "${srcdir}/dreamchess"
make DESTDIR="${pkgdir}" install
+
+ # removing man pages otherwise pacman complains of filesystem conflict.
+ # not sure where the bug is, someone can check it out later
+ rm -r ${pkgdir}/usr/local/share/man
}
# vim:set ts=2 sw=2 et: