summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8076a27daa7..b0cd8442b90a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
pkgname=('drill-search-cli' 'drill-search-gtk')
pkgbase=drill-search
-pkgver=1.253
-pkgrel=2
+pkgver=1.255
+pkgrel=1
arch=('x86_64')
url="https://www.drill.santamorena.me/"
license=('GPL2')
makedepends=('git' 'dmd' 'dub')
-_dubv=( "1.0.3" #datefmt
- "3.9.0" #gtkd
- )
+_dubv=("1.0.3" #datefmt
+ "3.9.0" #gtkd
+ )
install="$pkgbase.install"
source=("$pkgbase-$pkgver.tar.gz::https://github.com/yatima1460/Drill/archive/$pkgver.tar.gz"
"$pkgbase"
@@ -17,9 +17,9 @@ source=("$pkgbase-$pkgver.tar.gz::https://github.com/yatima1460/Drill/archive/$p
"$pkgbase-gtk.svg"
"datefmt::git+https://github.com/dhasenan/datefmt.git#tag=v${_dubv[0]}"
"gtkd::git+https://github.com/gtkd-developers/GtkD.git#tag=v${_dubv[1]}")
-sha256sums=('dcad7fee6ad9fd6ed0765178ecbab145f8a831cb2f1d89686a131ef91f052620'
+sha256sums=('2567d591b8438452faf47dcdcf90b433e2c4911d1f7d228a91365649ace078ba'
'b875f928546aee7855cb1db9afc8ab3f1a8a34d43de5bbd62f7076d7ba9f3917'
- '21a6d19b8198816b3a6e406198ee6e4d5ab0da134df26b8342837e810ccc26a9'
+ '5bafb37baf608a3168abba2ab9ea174a1d0f0472f52d3222ea0a05957c997c50'
'cbfbcebb2957223eaa9c915780a5d0ac47c1fac70b7944f49e8ffcfe740edc53'
'SKIP'
'SKIP')
@@ -39,14 +39,14 @@ build() {
--cache=local `# ensure dub stays outside the users home directory`\
--parallel `# runs multiple compiler instances in parallel, if possible`\
--force `# Forces a recompilation even if the target is up to date`\
- --build release \
+ --build=release \
cd .. && cd GTK
dub build \
--cache=local `# ensure dub stays outside the users home directory`\
--parallel `# Runs multiple compiler instances in parallel, if possible`\
--force `# Forces a recompilation even if the target is up to date:`\
- --build release \
+ --build=release \
# remove local dependencies from search path so dub won't find them
# again later
@@ -71,7 +71,7 @@ package_drill-search-cli() {
package_drill-search-gtk() {
pkgdesc="Search files without indexing, but clever crawling (GTK version)"
- depends=('gtk3')
+ depends=('gtk3' 'xdg-utils')
cd "Drill-$pkgver/Source/Frontend/GTK"
install -d $pkgdir/{opt/$pkgname,usr/bin}