summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e04f643fb9a..55c0429370d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,23 +12,23 @@ depends=('php')
makedepends=("php-box" "php-composer" "git")
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-source=("${_pkgname}-${pkgver}"::"git+https://github.com/drush-ops/drush.git")
+source=("${_pkgname}"::"git+https://github.com/drush-ops/drush.git")
sha512sums=('SKIP')
pkgver() {
- cd "${_pkgname}-${pkgver}"
+ cd "${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}"
php /usr/bin/composer install --no-dev
cp box.json.dist box.json
php -d phar.readonly=Off /usr/bin/php-box build
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}"
install -D -m755 "${_pkgname}.phar" "${pkgdir}/usr/bin/${_pkgname}"
install -D -m644 "examples/example.aliases.drushrc.php" "${pkgdir}/etc/drush/aliases.drushrc.php"
install -D -m644 "examples/example.drush.ini" "${pkgdir}/etc/drush/drush.ini"