summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 19 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index faa239a3523a..7769a7df0da3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,24 @@
-# Maintainer: Danilo Kuehn <dk[at]nogo-software[dot]de>
-
+# Maintainer: mark dot blakeney at bullet-systems dot net
+# Contributor: Danilo Kuehn <dk[at]nogo-software[dot]de>
_pkgname=dry
-_pkgver=v0.10-beta.1
-_pkgdownload=${_pkgname}_${_pkgver}
-pkgname=dry-bin
-pkgver=0.10
+pkgname=$_pkgname-bin
+pkgver=0.11.1
pkgrel=1
-pkgdesc="dry is a terminal application to manage Docker containers and images"
-url="http://moncho.github.io/dry/"
-arch=('x86_64' 'i686')
-license=('MIT')
-depends=('docker')
-if test "$CARCH" == i686; then
-source=(
- "${_pkgdownlad}::https://github.com/moncho/dry/releases/download/${_pkgver}/dry-linux-386"
-)
-sha256sums=(
- 'aea586a2d8f6e38c9f24a7757e954636248209a87480faea8a3e3f96021dd94a'
-)
-else
-source=(
- "${_pkgdownload}::https://github.com/moncho/dry/releases/download/${_pkgver}/dry-linux-amd64"
-)
-sha256sums=(
- 'e2865e54d5ff825b2a2b5f52b8271d86fd51eff868dd8a7cf3a7b81fa854a660'
-)
-fi
+pkgdesc="dry: a terminal application to manage Docker containers and images"
+url="http://moncho.github.io/$_pkgname/"
+arch=("x86_64" "i686" "armv7h" "aarch64")
+license=("MIT")
+depends=("docker")
+_pkgdownload=${_pkgname}_${pkgver}
+source_x86_64=("${_pkgdownload}-x86_64::https://github.com/moncho/$_pkgname/releases/download/v${pkgver}/$_pkgname-linux-amd64")
+source_i686=("${_pkgdownload}-i686::https://github.com/moncho/$_pkgname/releases/download/v${pkgver}/$_pkgname-linux-386")
+source_armv7h=("${_pkgdownload}-armv7h::https://github.com/moncho/$_pkgname/releases/download/v${pkgver}/$_pkgname-linux-arm")
+source_aarch64=("${_pkgdownload}-aarch64::https://github.com/moncho/$_pkgname/releases/download/v${pkgver}/$_pkgname-linux-arm64")
+sha256sums_x86_64=('91c1a91a031fec9fdc223a75321ef3b085904ee47d0523406d0c76596376f82a')
+sha256sums_i686=('9a25401a1d73be0483236301cad0dfa976c1b248fabbe0762637011d314acf39')
+sha256sums_armv7h=('31bc97d3ffc123ed4369a62ad58cf59ad9fed9e0968f90b4b4f28cbb63821cdc')
+sha256sums_aarch64=('7a08ea3fc03871d09e5b6c9c216ff25279c65f55af22915dc81ab6387893618f')
package() {
- install -Dm755 "${srcdir}/${_pkgdownload}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm755 "${srcdir}/${_pkgdownload}-$CARCH" "${pkgdir}/usr/bin/${_pkgname}"
}