summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 227d00204a6e..b39dcfed98f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,18 @@
# Maintainer: Lauri Niskanen <ape@ape3000.com>
+# Maintainer: Michael Barbour <barbour.michael.0@gmail.com>
# Contributor: sekret
pkgname=dsp-git
_pkgname=dsp
-pkgver=234.25a4b3e
+pkgver=241.6d1aa67
pkgrel=1
pkgdesc="An audio processing program with an interactive mode"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://github.com/bmc0/${_pkgname}"
license=('ISC')
-makedepends=('git' 'fftw' 'libsndfile' 'ffmpeg' 'alsa-lib' 'libao' 'libmad' 'libpulse' 'ladspa' 'zita-convolver')
-optdepends=('fftw: For resample and fir effects'
- 'libsndfile: For sndfile input/output support'
- 'ffmpeg: For ffmpeg input support'
- 'alsa-lib: For alsa input/output support'
- 'libao: For ao output support'
- 'libmad: For mp3 input support'
- 'libpulse: For PulseAudio input/ouput support'
- 'ladspa: For building the LADSPA frontend'
- 'zita-convolver: For zita_convolver effect')
-source=(${_pkgname}::"git+https://github.com/bmc0/${_pkgname}.git")
+makedepends=('git')
+depends=('fftw' 'libsndfile' 'ffmpeg' 'alsa-lib' 'libao' 'libmad' 'libpulse' 'ladspa' 'zita-convolver')
+source=("git+https://github.com/bmc0/${_pkgname}.git")
md5sums=('SKIP')
pkgver() {
@@ -30,10 +23,13 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
./configure --prefix=/usr
+ make
}
package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE.GPL2 "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.GPL2"
+ install -Dm644 LICENSE.LGPL2_1 "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.LGPL2_1"
}