summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f95217f9268..67bda0e78997 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Ian Young <ian at iangreenleaf dot com>
+# Contributor: Gunnar Bretthauer <taijian@posteo.de>
pkgname=duplicacy
-pkgver=2.2.1
-pkgrel=1
+pkgver=3.2.3
+pkgrel=2
pkgdesc="A new generation cloud backup tool based on lock-free deduplication"
arch=('x86_64' 'i686')
url="https://duplicacy.com/"
@@ -10,8 +11,10 @@ license=('custom')
depends=('glibc')
makedepends=('go' 'git')
source=("$pkgname-$pkgver.tar.gz::https://github.com/gilbertchen/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('8df1ae0e4b338e6fdcb74bf3996fbc6ff6fe362207e34befc4726bb6e64bca39')
+sha256sums=('8c8e30fb24a60e1a2c0cc11e0f408114163d6d911c7824000913fec88f31e32e')
+export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
prepare() {
cd "$pkgname-$pkgver/$pkgname"
@@ -23,7 +26,10 @@ prepare() {
build() {
cd "$pkgname-$pkgver/$pkgname"
-
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
GOPATH="$srcdir/$pkgname-$pkgver/$pkgname" go build -x
}