aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ef6ba561bd90..6b9d1c6c8a5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
pkgname=dwarffortress-lnp-git
-pkgver=42.06
-_pkgver=42_06
-_dfhack_pkgrel=beta1
+pkgver=43.03
+_pkgver=43_03
+_dfhack_pkgrel=r1
pkgrel=1
epoch=0
pkgdesc="Installer for the Lazy Newb Pack to run Dwarf Fortress. Includes vanilla dwarf fortress, dfhack and graphics"
@@ -40,11 +40,12 @@ changelog=
source=(git+"https://github.com/Lazy-Newb-Pack/Lazy-Newb-Pack-Linux"
git+"https://github.com/DFgraphics/DFgraphics.git"
git+"https://github.com/DFHack/dfhack.git"#"tag=0.${pkgver}-${_dfhack_pkgrel}"
- git+"https://github.com/svenstaro/dwarf_fortress_unfuck.git"
+ git+"https://github.com/svenstaro/dwarf_fortress_unfuck.git"#"tag=0.${pkgver}"
git+"https://github.com/mifki/df-twbt.git"
hg+"https://bitbucket.org/Pidgeot/python-lnp"
"http://bay12games.com/dwarves/df_${_pkgver}_linux.tar.bz2"
"DFAnnouncementFilter.zip"::"http://dffd.bay12games.com/download.php?id=7905&f=DFAnnouncementFilter.zip"
+ "pylnp-terminal.patch"
"dfhack-twbt.patch"
"dfhack-visualizers.patch"
"lnp"
@@ -60,8 +61,9 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '47f5a2ea1c4de2b742b50dd876b73feb'
+ '17d9ceb486fd476b4c6e8f0834d21d2e'
'affd6273731c321d364c55a8da314fea'
+ '35e4942313f50d35e58e9c2a51874a82'
'856c54681faed3608cd951bf286d12d5'
'5cc79b5dc202d8faa02086293badfcee'
'389e34b6937f843c8f635d5e7326c9fc'
@@ -114,10 +116,13 @@ prepare() {
-DCMAKE_EXE_LINKER_FLAGS:STRING="${LDFLAGS}" \
-DCMAKE_SHARED_LINKER_FLAGS:STRING="${LDFLAGS}"
+ cd $srcdir/python-lnp/core
+ patch -uN terminal.py $srcdir/pylnp-terminal.patch
+
}
build() {
- export DFHACKVER="${pkgver}-r5"
+ export DFHACKVER="${pkgver}-r3"
cd $srcdir/dwarf_fortress_unfuck
cd build
@@ -232,8 +237,7 @@ package() {
for license in python-lnp/COPYING.txt dfhack/depends/protobuf/COPYING.txt \
dfhack/plugins/stonesense/LICENSE dfhack/LICENSE.rst \
- dfhack/depends/lua/COPYRIGHT dfhack/scripts/3rdparty/maienm/LICENSE \
- dfhack/scripts/3rdparty/lethosor/LICENSE ; do
+ ; do
install -DTm644 "$srcdir/$license" \
"${pkgdir}/usr/share/licenses/${pkgname}/$license"
done