summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b5c0b202a7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
+pkgname=dwl
+pkgver=0.1
+pkgrel=1
+pkgdesc="Simple, hackable dynamic tiling Wayland compositor (dwm for Wayland)"
+arch=('x86_64')
+url="https://github.com/djpohly/dwl"
+license=('GPL')
+depends=('wlroots')
+source=("https://github.com/djpohly/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX="$pkgdir/usr/" install
+}