summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a15337610d6d..fb5d25a4e8d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
pkgname=dwl
pkgver=0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Simple, hackable dynamic tiling Wayland compositor (dwm for Wayland)"
arch=('x86_64')
url="https://github.com/djpohly/dwl"
@@ -16,7 +16,10 @@ sha256sums=('a3dd9b7107e9d324cc0dc4f48dd526fb687b10c9e63a42b33a827130d9113763'
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- cp "$srcdir/config.h" config.h
+ # Use a custom config.h if the file is not empty
+ if [ -s "$srcdir/config.h" ]; then
+ cp -f "$srcdir/config.h" config.h
+ fi
# Uncomment to compile with XWayland support
#sed -i -e '/-DXWAYLAND/s/^#//' config.mk
}