summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..d94f4bd4b342
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=dwm-git
+_pkgname=dwm
+pkgdesc="dwm with uleenucks personalisations"
+pkgver=6.1
+pkgver(){
+ cd $_pkgname
+ git describe --tags |sed 's/-/./g'
+}
+pkgrel=1
+pkgdesc="A dynamic window manager for X"
+url="http://dwm.suckless.org"
+arch=('i686' 'x86_64')
+license=('MIT')
+options=(zipman)
+depends=('libx11' 'libxinerama' 'libxft')
+makedepends=('git')
+install=dwm.install
+provides=('dwm')
+conflicts=('dwm')
+epoch=1
+source=("$_pkgname::git+http://git.suckless.org/dwm"
+ config.def.h
+ dwm-6.1-center.diff)
+
+. md5sums
+prepare() {
+ if [[ -f $SRCDEST/config.def.h ]]; then
+ ln -sf $SRCDEST/config.def.h $srcdir/dwm/config.h
+ fi
+}
+
+build() {
+ cd $_pkgname
+
+ patch -p1 < ../dwm-6.1-center.diff || exit 1
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ make -C $_pkgname PREFIX=/usr DESTDIR=$pkgdir install
+ install -m644 -D $_pkgname/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -m644 -D $_pkgname/README $pkgdir/usr/share/doc/$pkgname/README
+}
+
+# vim:set ts=2 sw=2 et: