summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 20 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cebf8339052..aad0630268cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgbase=dxvk-git
pkgname=('dxvk-mingw-git')
-pkgver=1.5.r3.ga265af74
-pkgrel=2
+pkgver=1.10.1.r695.g87b1f9fa
+pkgrel=1
pkgdesc="A Vulkan-based compatibility layer for Direct3D 9/10/11 which allows running 3D applications on Linux using Wine. Windows DLL version)"
arch=('x86_64')
url="https://github.com/doitsujin/dxvk"
@@ -13,8 +13,15 @@ provides=("dxvk" "d9vk" "dxvk=$pkgver")
makedepends=('ninja' 'meson>=0.43' 'glslang' 'mingw-w64-gcc' 'git' 'wine')
conflicts=('d9vk-mingw-git' 'd9vk-bin' 'd9vk-winelib-git' "dxvk-bin" "dxvk-git" "dxvk-wine32-git" "dxvk-wine64-git" "dxvk-win32-git" "dxvk-win64-git" "dxvk-winelib-git")
options=(!strip !buildflags staticlibs)
-source=("git+https://github.com/doitsujin/dxvk.git")
-sha256sums=("SKIP")
+source=("git+https://github.com/doitsujin/dxvk.git"
+"https://github.com/Joshua-Ashton/mingw-directx-headers"
+"https://github.com/KhronosGroup/Vulkan-Headers"
+"https://github.com/KhronosGroup/SPIRV-Headers.git"
+)
+sha256sums=("SKIP"
+"SKIP"
+"SKIP"
+"SKIP")
pkgver() {
@@ -22,6 +29,15 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//g'
}
+prepare() {
+ cd dxvk
+ git submodule init
+ git config submodule.mingw-directx-headers.url "$srcdir/include/native/directx"
+ git config submodule.Vulkan-Headers.url "$srcdir/include/vulkan"
+ git config submodule.SPIRV-Headers.git.url "$srcdir/include/spirv"
+ git submodule update
+}
+
build() {
meson dxvk "build/x64" \
--cross-file dxvk/build-win64.txt \