summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 896a2158155d..435d68a88d0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# Maintainer: Malstrond <malstrond@gmail.com>
-# Contributor: xduugu
+# Maintainer: Taijian <taijian@posteo.de>
+# Contributor: Malstrond <malstrond@gmail.com>
+# Contributor: xduugu
pkgname=dyndnsc
-pkgver=0.5.1
-pkgrel=0
+_pkgname=python-dyndnsc
+pkgver=0.6.0
+pkgrel=1
pkgdesc="Dynamic DNS client with support for multiple protocols and services. Compatible with IPv6 dual stack."
arch=('any')
url="https://pypi.org/project/dyndnsc"
license=('MIT')
-depends=('python-argparse' 'python-ipy' 'python-ndg-httpsclient' 'python-requests' 'python-setuptools' 'python-netifaces')
-source=("https://pypi.python.org/packages/source/d/dyndnsc/dyndnsc-$pkgver.tar.gz"
+depends=('python-requests' 'python-setuptools' 'python-netifaces' 'python-dnspython' 'python-daemonocle' 'python-json-logger')
+makedepends=('python-pip' 'python-wheel')
+source=("https://github.com/infothrill/$_pkgname/archive/$pkgver.zip"
'dyndnsc.service')
-md5sums=('55bc511dbc6d9a9d46f89bcfaa70f37c'
- '4b2cd825c387494ba77ad78106dd42eb')
+sha256sums=('ff0fcd735e96a958fdce51910d962f064c0da6b4b9723e929c1a1e5de2570df0'
+ '06e5088696dd2cd6e9af9de51bf0c88e94adadd582cd66620bc260caaf56059c')
build() {
- cd "$srcdir/dyndnsc-$pkgver"
+ cd "$_pkgname-$pkgver"
python setup.py build
}
package() {
- cd "dyndnsc-$pkgver"
+ cd "$_pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
# install systemd service file