summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 155979b2aacc..578347e924a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Contributor: Kevin Piche <kevin@archlinux.org>
# Contributor: Manolis Tzanidakis
pkgname=e2guardian
-pkgver=3.4.0.3
+pkgver=3.5.1
pkgrel=1
pkgdesc="Fork of dansguardian, an open source web content filter. It filters the actual content of pages based on many methods including phrase matching, request header and URL filtering, etc. It does not purely filter based on a banned list of sites."
url="http://e2guardian.org"
-arch=('i686' 'x86_64' 'armv6h' 'arm')
+arch=('i686' 'x86_64' 'armv6h' 'arm' 'armv7h')
license=('GPL2')
makedepends=('grep' 'gzip' 'zlib')
depends=('pcre' 'perl')
@@ -18,9 +18,9 @@ install=${pkgname}.install
source=(https://github.com/e2guardian/${pkgname}/archive/v${pkgver}.tar.gz
e2guardian
e2guardian.service)
-sha1sums=('83c7f9033d232f53af3f38743128ce99b549924c'
- '4505b1e66cc1f64b06eacb277de24c453831f215'
- 'a4179286aa0d0bf3bb71f5459075a02ceaf0d518')
+sha1sums=('ba9190e35c937e934273d1f64aa2f08dbcc489ad'
+ '4505b1e66cc1f64b06eacb277de24c453831f215'
+ 'a4179286aa0d0bf3bb71f5459075a02ceaf0d518')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
@@ -38,7 +38,6 @@ package() {
install -d ${pkgdir}/usr/bin
install -D data/scripts/e2guardian ${pkgdir}/etc/logrotate.d/e2guardian
install -D -m644 ${srcdir}/e2guardian.service ${pkgdir}/usr/lib/systemd/system/e2guardian.service
- rmdir "$pkgdir/var/run"
}
backup=(etc/e2guardian/e2guardian.conf