summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e7104ffa32a..ef59f1cc41c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Léo Chéneau <leocheneau+arch@gmail.com>
pkgname=easena-git
-pkgver=r441.07415e8
+pkgver=r449.g33c1f75
pkgrel=2
pkgdesc="EAsy Specification of Evolutionary and Neural Algorithms is an Artificial Evolution platform developped by the SONIC (Stochastic Optimisation and Nature Inspired Computing) group of the BFO team at Université de Strasbourg. "
arch=(i686 x86_64)
url="http://easea.unistra.fr"
license=('AGPL3')
-depends=(cmake flex bison valgrind java-environment cuda r)
+depends=(cmake flex bison valgrind)
makedepends=(make gcc)
provides=(easena easea)
conflicts=(easea)
@@ -24,15 +24,15 @@ pkgver() {
prepare() {
cd easea
#patch --forward --strip=1 --input="${srcdir}/fix_config.patch"
+ cmake -B build -DCMAKE_BUILD_TYPE=Release
}
build() {
cd easea
- cmake .
- make
+ cmake --build build --config Release
}
package() {
cd easea
- make DESTDIR="$pkgdir/" install
+ cmake --install build --prefix "$pkgdir"
}