summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46733d7f162b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
+pkgname='easybuild-easyconfigs-git'
+pkgver=3.5.1.r142.g0c1a5150e
+pkgrel=1
+pkgdesc="A software build and installation framework for HPC systems"
+arch=('any')
+groups=('easybuild-git')
+url="https://github.com/easybuilders/easybuild-easyconfigs"
+license=('GPL')
+depends=('python2' 'easybuild-easyblocks-git')
+makedepends=('git' 'python2-setuptools')
+source=('git+https://github.com/easybuilders/easybuild-easyconfigs.git#branch=develop')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/easybuild-easyconfigs"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/.*v\(.*\)$/\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/easybuild-easyconfigs"
+ python2 setup.py install --root "$pkgdir"
+}