summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59b19f10c130..98862bd9e8c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Malacology <guoyizhang at malacology dot com>
pkgname=easycodeml
-pkgver=1.21
+pkgver=1.4
pkgrel=1
-pkgdesc="A visual tool for analysis of selection using CodeML"
+pkgdesc="A visual tool for analysis of selection using CodeML. https://doi.org/10.1002/ece3.5015"
arch=('x86_64')
url="https://github.com/BioEasy/EasyCodeML"
-license=('unknow')
-source=("https://github.com/starsareintherose/easycodeml/releases/download/${pkgver}/EasyCodeML.zip" "easycodeml.desktop" "EasyCodeML.png")
-sha256sums=('45ef18a896818643908dc3ad637da7773f6d984e75f8a6faa61992a7d8e48776'
+license=('LGPL3')
+source=("https://raw.githubusercontent.com/BioEasy/EasyCodeML/master/EasyCodeML.jar" "easycodeml.desktop" "EasyCodeML.png")
+sha256sums=('16eef77a21be47ac2b2cf2e04ded75dc76546a71e0ca227aa21e0418ec8caf36'
'e20af3e0e14be4f95d634bf5c34cb35dc37edfada7d97f9c0e9dd10afa7cbf6f'
'5393db9477bd071511788ea6255c49005274b4aebe792a7631eaa296ada14987')
depends=(
@@ -17,7 +17,7 @@ depends=(
)
package() {
install -dm755 "$pkgdir"/usr/share/{EasyCodeML,applications}
- mv "$srcdir"/EasyCodeML/* "$pkgdir"/usr/share/EasyCodeML
+ install -Dm 755 "$srcdir"/EasyCodeML.jar "$pkgdir"/usr/share/EasyCodeML
install -m 755 ${srcdir}/EasyCodeML.png ${pkgdir}/usr/share/EasyCodeML/EasyCodeML.png
install -m 755 ${srcdir}/easycodeml.desktop ${pkgdir}/usr/share/applications/easycodeml.desktop
}