summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cf55632128b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Rafael Silva <perigoso@riseup.net>
+
+pkgname=easyeda2kicad
+pkgver=1.9.2
+pkgrel=1
+pkgdesc="Convert EasyEDA designs to KiCad EDA"
+arch=('any')
+url="https://github.com/wokwi/easyeda2kicad"
+makedepends=('npm')
+license=('MIT')
+#noextract=("${pkgname}-${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/wokwi/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('378fff1370e85b4cbd5956fc53907b7de90ae8f910d53ba13c98fecac416fb23')
+
+package() {
+ cd ${pkgname}-${pkgver}
+ npm install -g --prefix "${pkgdir}/usr" ${pkgname}
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
+ chown -R root:root "${pkgdir}"
+}