summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4cc99af0917..01fd90fb09ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Max Bruckner
pkgname=easyhg
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Simple user interface for the Mercurial distributed version contol system."
arch=('i686' 'x86_64')
url="http://easyhg.org"
@@ -10,18 +10,20 @@ depends=('qt4' 'mercurial')
optdepends=('pyqt: authentication extension'
'python-crypto: password store'
'kdiff3: external diff/merge tool')
-source=(https://code.soundsoftware.ac.uk/attachments/download/639/EasyMercurial-1.3.0-src.tar.gz)
-md5sums=('728858917b2b121e2ee7ce160ff4151f')
+source=("https://code.soundsoftware.ac.uk/attachments/download/639/EasyMercurial-$pkgver-src.tar.gz"
+ easyhg.desktop
+)
+md5sums=('728858917b2b121e2ee7ce160ff4151f'
+ 'd4362bd25f61606a67bbe27bbfacbeeb')
build() {
- cd "$srcdir/EasyMercurial-1.3.0-src"
+ cd "$srcdir/EasyMercurial-$pkgver-src"
qmake-qt4
make
}
package() {
- cd "$srcdir/EasyMercurial-1.3.0-src"
- mkdir "$pkgdir/usr"
- mkdir "$pkgdir/usr/bin"
- cp EasyMercurial "$pkgdir/usr/bin/easyhg"
+ install -Dm 755 "$srcdir/EasyMercurial-$pkgver-src/EasyMercurial" "$pkgdir/usr/bin/easyhg"
+ install -Dm 644 "$srcdir/EasyMercurial-$pkgver-src/images/icon/scalable/easyhg-icon.svg" "$pkgdir/usr/share/pixmaps/easyhg.svg"
+ install -Dm 644 "$srcdir/easyhg.desktop" "$pkgdir/usr/share/applications/easyhg.desktop"
}