summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f53b217948d8..2bf435875a37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=easyrpg-tools-git
-pkgver=r39.e185825
+pkgver=r50.aea33a2
pkgrel=1
pkgdesc="EasyRPG tools to convert RPG Maker 2000/2003 files (development version)"
arch=('i686' 'x86_64')
url="https://easy-rpg.org/"
-license=('MIT' 'GPL' 'custom')
+license=('MIT' 'GPL3' 'custom')
conflicts=('lcf2xml')
-provides=('lcf2xml' 'lmu2png' 'xyz2png')
+provides=('lcf2xml' 'lmu2png' 'png2xyz' 'xyz2png')
makedepends=('git')
-depends=('gcc-libs' 'liblcf-git' 'sdl2_image')
+depends=('gcc-libs' 'liblcf-git' 'sdl2_image' 'libpng')
source=(${pkgname#-*}::"git+https://github.com/EasyRPG/tools.git")
md5sums=('SKIP')
@@ -23,6 +23,7 @@ build () {
cd ${pkgname#-*}
make -C lmu2png
+ make -C png2xyz
make -C xyz2png
# compile with our flags
g++ $CXXFLAGS lcf2xml/src/main.cpp $(pkg-config --cflags --libs liblcf) $LDFLAGS -o lcf2xml/lcf2xml
@@ -33,10 +34,10 @@ package () {
# executables
install -Dm755 lmu2png/lmu2png "$pkgdir"/usr/bin/lmu2png
+ install -Dm755 xyz2png/xyz2png "$pkgdir"/usr/bin/png2xyz
install -Dm755 xyz2png/xyz2png "$pkgdir"/usr/bin/xyz2png
install -Dm755 lcf2xml/lcf2xml "$pkgdir"/usr/bin/lcf2xml
# licenses
install -Dm644 lmu2png/COPYING "$pkgdir"/usr/share/licenses/$pkgname/lmu2png-COPYING
- install -Dm644 xyz2png/COPYING "$pkgdir"/usr/share/licenses/$pkgname/xyz2png-COPYING
install -Dm644 lcf2xml/COPYING "$pkgdir"/usr/share/licenses/$pkgname/lcf2xml-COPYING
}