summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-x[-rw-r--r--]PKGBUILD26
1 files changed, 10 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce83ac719bb2..9ecd9bddce32 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,25 @@
-# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Maintainer: Raymond Li <aur@raymond.li>
+# Co-maintainer: Steve Finkel <mrsteve0924@verizon.net>
+# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Kevin Sullivan <ksullivan@archlinux.us>
pkgname=easystroke
pkgver=0.6.0
-pkgrel=22
-pkgdesc='Use mouse gestures to initiate commands and hotkeys.'
+pkgrel=23
+pkgdesc='Use mouse gestures to initiate commands and hotkeys'
arch=('x86_64')
-url='http://easystroke.sourceforge.net/'
+url='https://github.com/mrsteve0924/easystroke'
license=('custom:ISC')
depends=('gtkmm3' 'boost-libs' 'libxtst' 'dbus-glib' 'xorg-server')
makedepends=('boost' 'xorgproto' 'intltool' 'gettext' 'xorg-server-devel' 'help2man')
-source=("https://downloads.sourceforge.net/easystroke/${pkgname}-${pkgver}.tar.gz"
- 'easystroke-0.6.0-gcc7-build-fix.patch'
- 'replace-sigc-group-with-lambda.patch')
-sha512sums=('a74cbdfd2b56e6b20d895297e80fb63f3d8ac938235ecf7067f984d087004af22a5ea0116ae20b948e238b02a06b14044a7025d65840f0c8d00542332387c921'
- 'ab243cd570a4878767bfc64f39dbf6cc938bf050b50e4ac3bfe5036f5fbdd21eeeedc5cf89784a4f73f78233132b981d00087482835430d240f0b55e16d1acb4'
- '30b3a50b3434b22d3aed75f8c023eafb78f6980a23c506e9ed70e8787fd2786a1a882468b5c8334e3161c241c1878f8b4f9ba0178e07aad0388d44522e70c245')
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mrsteve0924/${pkgname}/archive/v${pkgver}.tar.gz")
+
+sha256sums=('c5851abd8b1b77d494eff108b2c0e2cc8cf689800bcfb2eead9f5e68274b37f9')
prepare() {
cd "${pkgname}-${pkgver}"
- # Fix compilation with GCC 7.
- patch -Np1 -i ../easystroke-0.6.0-gcc7-build-fix.patch
-
- # fix build with libsigc++ 2.6; also build in C++11 mode
- # (not sure if the lambda is correct, but seems to work)
- patch -Np1 -i ../replace-sigc-group-with-lambda.patch
}
build() {